Subject: Re: naming conventions for slot accessors
From: (Rob Warnock)
Date: Tue, 28 Oct 2008 06:01:56 -0500
Newsgroups: comp.lang.lisp
Message-ID: <>
Peder O. Klingenberg <> wrote:
| (Rob Warnock) writes:
| > One situation where "-of" (and similar suffixes) might be useful
| > is where the accessor name you'd naturally want to used is already
| > defined as a function inherited from the CL package
| But religiously having an "-of" suffix can be irritating as well.
| We have heaps of automatically generated classes using that suffix.
| Causes endless irritation whenever we want to access the slot called
| "type".

Er... yes, well... I *did* say "might be useful"...  ;-}  ;-}

If you "have heaps of automatically generated classes", rather
than adding the "-OF" suffix it might be better to name all your
automatically generated classes and their slots in a separate
package [that *doesn't* USE the CL package!], and use "PKG:" prefixes
on all the class & slot references. If the package name is one
or two characters long, it needn't be less convenient than the
"-OF" suffix, e.g., O:MAX versus MAX-OF.


Rob Warnock			<>
627 26th Avenue			<URL:>
San Mateo, CA 94403		(650)572-2607